Verbindung zu SQL-Server läuft auf Automatisierungsfehler
willi154
Gesendet: 26.06.20 11:59
Betreff: Verbindung zu SQL-Server läuft auf Automatisierungsfehler


Member

Beiträge: 15

Hallo Zusammen,

ich habe ein kurioses Problem. Ich habe eine FE/BE DB auf ca 20 PC (Win10/Office2010) ohne Probleme am Lauft.
Gestern haben wir einen neuen PC (komplett gleich zu den 20 bisherigen) ausgebracht und darauf auch dieses FE installiert.

Beim Start dieser Anwendung wird als erstes eine Connection zu unserem SQLServer hergestellt - dass funktioniert auch bei den bisherigen 20 PC's ohne Problem,
nur der Neue macht hier Probleme

==> -2147024770 Automatisierungsfehler - Das angegebene Modul wurde nicht gefunden

Wir haben auf den PC schon mit einem neuen Profil getestet und auch Office komplett nochmal neu installiert - ohne Erfolg.

Beim Debugging erzeugt die Zeile die Fehlermeldungen
Hier ein Auszug aus dem Code (Benutzer und PW werden natürlich mitgegeben):

Function MyConnectString(Benutzer, PW) As String
MyConnectString = "Provider=sqloledb;Data Source=Server-E;Initial Catalog=US_MitarbeiterSQL;" & _
"User Id=" & Benutzer & ";Password=" & PW & ";"


End Function

Sub anmelden(user, PW)
Dim DBCon As ADODB.Connection
On Error GoTo ErrorHandler



'Connection zu SQL-Server wird hergestellt
Wiederholung:
ConStr = MyConnectString(user, PW)
Set DBCon = New ADODB.Connection
DBCon.ConnectionString = ConStr
DBCon.CursorLocation = adUseClient
DBCon.Open
Set cnn = DBCon
DoCmd.Close acForm, "For_Anmeldung"
Exit Sub


ErrorHandler: ' Error-handling routine.
Debug.Print Err.Number ' Evaluate error number.
Debug.Print Err.Description ' Evaluate error number.
If MsgBox("Anmeldung fehlerhaft - Wiederholen?", vbYesNo) = vbYes Then
'Resume Wiederholung
Else

Ich hoffe Ihr könnte mir hier weiterhelfen

Danke
Gruß
Willi
Top of the page Bottom of the page