Unterformular / Access 2013
Karl Donaubauer
Gesendet: 17.06.21 17:34
Betreff: RE: Unterformular / Access 2013



Elite Veteran

Beiträge: 857
5001001001002525
Ort: Wien
Hallo, Andreas!

Andreas - 17.06.21

ich kann in einem Unterformular keine Daten mehr anfügen.
Das heisst, es hat mal funktioniert.
Ich habe dann mit Sperren des Hauptfomulars gearbeitet und auch das Unterformular gesperrt.
Geht so was nicht ?? Macht man so was nicht ??

Private Sub Form_Load()
' Formular sperren
Me.AllowEdits = False
Me!UForm_Projekt_Awf.Form.AllowEdits = False
...
Auch wenn ich alles Sperren und Entsperren lasse, kann ich mit dem Unterformular keine neuen Datensätze erzeugen.
Das Unterformular allein geöffnet, erlaubt das Anhängen von Datensätzen.

Hat jemand eine Idee ?

1. Ist nur das Anhängen neuer Datensätze umöglich oder auch das Ändern von bestehenden?
Falls ersteres solltest du prüfen, ob irgendwo im Code auch die Eigenschaft "AllowAdditions" gesetzt wird.

2. Ansonsten einfache Testreihe:
a. Neues Formular in Entwurfsansicht öffnen und das Formular, das als UFo verwendet wird, in das neue ziehen. Klappt alles, dann weiter mit
b. Im bestehenden Hauptformular das UFo-Steuerelement löschen und das UFo neu reinziehen. Wie sieht es jetzt aus? Falls das UFo wieder nicht aktualisierbar ist, dann
c. Den kompletten Code im Hauptformular testweise löschen bzw. auskommentieren. Wie sieht es jetzt aus?

-----
Servus
Karl
*********
Access-Entwickler-Konferenz: https://www.donkarl.com/?aek
Access DevCon Vienna: https://www.donkarl.com/devcon
Access Forever: https://www.accessforever.org
Access News: https://www.youtube.com/playlist?list=PLVCeBbJIMDvdJ8ghMbEakJ6_EQyvy...
Top of the page Bottom of the page