Suche | Statistiken | Benutzerliste | Access-FAQ | Datenschutz Foren
donkarl Forum
donkarl Forum ->  Themen -> Access -> Diskussion ansehen

Du bist als Gast eingelogt. ( Anmelden | Registrieren )
  • alte mdw aktualisieren
  • StefanWirrer05.02.15 16:02
       └ RE: alte mdw aktualisieren StefanWirrer12.02.15 13:41
          └ RE: alte mdw aktualisieren Karl Donaubauer12.02.15 18:00
             └ RE: alte mdw aktualisieren StefanWirrer13.02.15 10:18
  • A2007 printout verursacht fehler 2052 (nicht genüg...
  • hochlenert10.02.15 08:56
       └ RE: A2007 printout verursacht fehler 2052 (nicht... Karl Donaubauer10.02.15 16:34
          └ RE: A2007 printout verursacht fehler 2052 (nic... hochlenert13.02.15 07:46
  • Access Stammtisch München am 12.2.2015 (Do)
  • StefanWirrer10.02.15 08:51
  • Langsamer Formularaufbau
  • HQbauer30.01.15 00:46
       └ RE: Langsamer Formularaufbau HQbauer30.01.15 15:47
          └ RE: Langsamer Formularaufbau Karl Donaubauer02.02.15 13:45
             └ RE: Langsamer Formularaufbau HQbauer03.02.15 12:46
                └ RE: Langsamer Formularaufbau HQbauer05.02.15 07:03
  • Mehre Tabellen in einem Formula
  • U92E02.02.15 13:43
       └ RE: Mehre Tabellen in einem Formula Karl Donaubauer02.02.15 13:58
          └ RE: Mehre Tabellen in einem Formula U92E02.02.15 14:25
             └ RE: Mehre Tabellen in einem Formula Karl Donaubauer02.02.15 15:06
       └ RE: Mehre Tabellen in einem Formula U92E02.02.15 15:35
       └ RE: Mehre Tabellen in einem Formula U92E04.02.15 19:10
  • SQL Findet Tabelle nicht
  • U92E03.02.15 14:24
       └ RE: SQL Findet Tabelle nicht Karl Donaubauer03.02.15 15:42
       └ RE: SQL Findet Tabelle nicht U92E03.02.15 17:01
          └ RE: SQL Findet Tabelle nicht Karl Donaubauer03.02.15 20:34
  • nicht erkennbares Datenformat
  • Helmut03.02.15 09:30
  • A 2007 zweistelliges Feld befüllt leere Stellen mi...
  • hochlenert26.01.15 14:43
       └ RE: A 2007 zweistelliges Feld befüllt leere Stel... Karl Donaubauer26.01.15 14:53
          └ RE: A 2007 zweistelliges Feld befüllt leere St... hochlenert26.01.15 18:31
  • ACC03 mit ADO - unerwünschte Konvertierung Zeic...
  • Christian Kehl22.01.15 11:07
  • Aktionsabfrage - mehrfache Ausführung
  • bhausu19.01.15 19:46
       └ RE: Aktionsabfrage - mehrfache Ausführung wilo20.01.15 11:08
          └ RE: Aktionsabfrage - mehrfache Ausführung bhausu20.01.15 14:10
  • Vortrag zu Ribbons beim Access-Stammtisch Rhein-Ma...
  • Martin Asal16.01.15 20:02
  • "Berechnung läuft...", Navibereich nicht...
  • Lorenz13.01.15 20:06
       └ RE: "Berechnung läuft...", Navibereich... Lorenz16.01.15 09:13
          └ RE: "Berechnung läuft...", Naviberei... Karl Donaubauer16.01.15 17:24
  • Frontend / Backend Auswirkung auf Abfragen
  • SenSoden11.01.15 20:18
       └ RE: Frontend / Backend Auswirkung auf Abfragen Karl Donaubauer12.01.15 11:06
          └ RE: Frontend / Backend Auswirkung auf Abfragen SenSoden12.01.15 19:23
  • WENN-Funktion in Abfrageentwurf
  • r.gottier18.12.14 06:46
       └ RE: WENN-Funktion in Abfrageentwurf Karl Donaubauer18.12.14 14:34
          └ RE: WENN-Funktion in Abfrageentwurf r.gottier21.12.14 08:14
             └ RE: WENN-Funktion in Abfrageentwurf Karl Donaubauer22.12.14 09:47
                └ RE: WENN-Funktion in Abfrageentwurf r.gottier26.12.14 12:25
                   └ RE: WENN-Funktion in Abfrageentwurf Karl Donaubauer31.12.14 16:19
                      └ RE: WENN-Funktion in Abfrageentwurf r.gottier10.01.15 19:08
  • Access Stammtisch München am 08.01.2015 (Do.)
  • StefanWirrer07.01.15 17:39
    Christian Kehl
    Gesendet: 22.01.15 11:07
    Betreff: ACC03 mit ADO - unerwünschte Konvertierung Zeichen


    Member

    Beiträge: 11

    Hallo,

    wir verwenden eine ACC03-ADP an einem SQL2008-1 Server.
    Wir haben momentan das Problem, das Zeichen in einem String nicht korrekt an den Server übergeben werden.
    Konkret geht es um slowakisch und hier zum Beispiel um das kleine c mit Caron, in der Zeichentabelle ist das die 010D.
    Wenn ich das Zeichen in einem Textfeld t1 mit einem Update an den Server schicke, wird immer in das normale kleine c umgewandelt.
    Beim Ausführen von

    "UPDATE tblTest set Testfeld = '" & me!t1 & "'"

    wird schon das kleine c an den Server übergeben.

    ASC(me!t1) liefert 99 (kleines c)
    ASCW(me!t1) liefert 259 (korrektes kleines c mit Caron).

    me!t2 = ASCW(me!t1) funktioniert.
    me!t2 = StrConv(me!t1, vbUnicode) liefert so etwas wie ein TAB.

    Die Rückkonvertierung funktioniert wieder soweit, um ein Textfeld richtig zu befüllen:

    me!t2 = StrConv(StrConv(me!t1, vbUnicode), vbFromUnicode) ist korrekt.

    Wenn ich das aber mit

    "UPDATE tblTest set Testfeld = '" & StrConv(StrConv(me!t1, vbUnicode), vbFromUnicode) & "'"

    an den SQL-Server schicke, wird wieder das kleine c geschickt, dh es kommt schon falsch beim Server an.

    Das Problem tritt nicht auf bei gebundenen Fomularen, da funktioniert alles, wie es soll. Der Umbau des betroffenen relativ komplexen ungebundenen Formulars würde Arbeitsaufwand bedeuten, den wir uns natürlich gerne sparen würden :-).

    Danke für alle Ideen oder Anregungen!

    Viele Grüße,
    Christian
    Top of the page Bottom of the page


    Seite: < 43 44 45 46 47 48 ... 49 50 51 52 53 54 55 ... >
    Suche in diesem Forum
    Druckfreundliche Version
    (Alle Cookies von dieser Seite löschen.)