Suche | Statistiken | Benutzerliste | Access-FAQ | Datenschutz Foren
donkarl Forum
donkarl Forum ->  Themen -> Access -> Diskussion ansehen

Du bist als Gast eingelogt. ( Anmelden | Registrieren )
  • Import-Spezifikation
  • Marzer15.07.20 18:30
       └ RE: Import-Spezifikation PeterDoering16.07.20 01:26
          └ RE: Import-Spezifikation Marzer19.07.20 21:53
  • Verbindung zu SQL-Server läuft auf Automatisierung...
  • willi15426.06.20 11:59
       └ RE: Verbindung zu SQL-Server läuft auf Automatis... willi15409.07.20 09:23
  • Access Stammtisch München am 09.07.2020 (Do)
  • StefanWirrer09.07.20 08:30
  • nochmals Access 2016 Runtime - Absturz - Bug?
  • Mario Nestelberger03.07.20 19:46
  • Runtime Version von Access 2016 ein Scherz ?
  • Neuling23.06.20 18:40
       └ RE: Runtime Version von Access 2016 ein Scherz ? Karl Donaubauer24.06.20 09:50
  • Typen unverträglich
  • SoeSchi23.06.20 07:34
       └ RE: Typen unverträglich PeterDoering23.06.20 11:54
          └ RE: Typen unverträglich SoeSchi23.06.20 14:45
  • Der virtuelle Access-Stammtisch
  • Martin Asal22.06.20 21:41
  • Ungebundenes Textfeld zeigt nur 255 Zeichen an
  • wienerbergpeter19.06.20 10:25
       └ RE: Ungebundenes Textfeld zeigt nur 255 Zeichen ... Karl Donaubauer19.06.20 18:08
          └ RE: Ungebundenes Textfeld zeigt nur 255 Zeiche... wienerbergpeter20.06.20 12:13
  • Fehler beim Lesen eines Recordsets
  • Markus Wenger19.06.20 09:59
       └ RE: Fehler beim Lesen eines Recordsets Karl Donaubauer19.06.20 18:01
  • Unterschiedliche Unterformulare aus einem ungeb...
  • MarkusC16.06.20 10:36
       └ RE: Unterschiedliche Unterformulare aus einem un... PeterDoering16.06.20 13:43
  • Word starten - aber im Vollbild
  • Neuling10.06.20 17:22
       └ RE: Word starten - aber im Vollbild PeterDoering10.06.20 22:59
          └ RE: Word starten - aber im Vollbild Neuling11.06.20 19:08
             └ RE: Word starten - aber im Vollbild Karl Donaubauer11.06.20 21:27
  • SQL-Suche ergibt falsches Ergebnis
  • DKKABG10.06.20 08:18
       └ RE: SQL-Suche ergibt falsches Ergebnis PeterDoering10.06.20 09:08
          └ RE: SQL-Suche ergibt falsches Ergebnis DKKABG10.06.20 09:15
             └ RE: SQL-Suche ergibt falsches Ergebnis PeterDoering10.06.20 22:46
  • Abfrage in Text-File exportieren
  • Dreho5208.06.20 17:29
       └ RE: Abfrage in Text-File exportieren Karl Donaubauer08.06.20 18:36
       └ RE: Abfrage in Text-File exportieren PeterDoering08.06.20 18:38
          └ RE: Abfrage in Text-File exportieren Karl Donaubauer08.06.20 18:44
             └ RE: Abfrage in Text-File exportieren PeterDoering08.06.20 19:55
                └ RE: Abfrage in Text-File exportieren Dreho5208.06.20 23:20
                   └ RE: Abfrage in Text-File exportieren Karl Donaubauer08.06.20 23:40
       └ RE: Abfrage in Text-File exportieren aber .... Dreho5209.06.20 09:46
          └ RE: Abfrage in Text-File exportieren aber .... Karl Donaubauer10.06.20 21:04
  • Office, klick und Los Version
  • Greiff10.06.20 09:40
       └ RE: Office, klick und Los Version Karl Donaubauer10.06.20 09:51
          └ RE: Office, klick und Los Version Greiff10.06.20 11:23
             └ RE: Office, klick und Los Version Karl Donaubauer10.06.20 12:15
  • Formular verlassen
  • Neuling09.06.20 17:08
       └ RE: Formular verlassen PeterDoering10.06.20 01:04
    MarkusC
    Gesendet: 16.06.20 10:36
    Betreff: Unterschiedliche Unterformulare aus einem ungebundem (Menü-)Formular öffnen.


    New user

    Beiträge: 1

    Hallo,
    ich baue gerade eine Datenbank auf in der unter anderem verschiedene Daten in speziellen Formulare eingegeben werden können. Folgendes Problem:

    Im Eingabeformular (EF1) gibt es ein Navigationssteuerelment mit dem ich bereits die verschieden Unterformulare(UFo 1-4) aufrufen kann. Nun möchte ich aus meinem ungebundenem Formular (HF1), welches als Menüführung dient, das Eingabeformular EF1 und dass dazugehörige UFo 1 öffnen welches aber nicht klappt.

    Folgenden Ansatz habe ich.
    Im HF1 öffne ich per Mausklick auf einen Button einen Sub in einem Modul:

    _Form_01-Menü:_________________________________________________
    Private Sub Befehl13_Click()

    Menu (1)

    End Sub
    ______________________________________________________________

    _Modul 1:______________________________________________________
    Option Compare Database

    Public i As Integer

    Public Sub Menu(i)

    Select Case i

    Case 1: DoCmd.OpenForm "02-Eingabeformular"
    'Forms![02-Eingabeformular]![Untergeordnet220].SetFocus
    Forms!Untergeordnet220.SourceObject = "021-UFo Eingabefunktion Typen"

    Case 2: 'Für die Öffnung der des UF2 in EF1
    Case 3: 'Für die Öffnung der des UF3 in EF1
    Case 4: 'Für die Öffnung der des UF4 in EF1

    End Select
    End Sub
    ______________________________________________________________

    Untergeordnet220 ist hierbei das Steuerelement "Unterformular/-bericht" in dem das UFo 1-4 erscheinen soll. Als Fehler kommt jetzt: Laufzeit Fehler 2450, MS Access kann das Formular 'Untergeordnet220' nicht finden, auf das verwiesen wird.
    Ich weiß das Untergeordnet220 kein Formular ist sondern ein Steuerelemnt aber ich habe keine Ahnung wie den Code umschreiben muss. Ich bitte um Hilfe
    Top of the page Bottom of the page


    Seite: < 1 2 3 4 5 6 7 8 9 10 11 ... >
    Suche in diesem Forum
    Druckfreundliche Version
    (Alle Cookies von dieser Seite löschen.)