Suche | Statistiken | Benutzerliste | Access-FAQ | Datenschutz Foren
donkarl Forum
donkarl Forum ->  Themen -> Access -> Diskussion ansehen

Du bist als Gast eingelogt. ( Anmelden | Registrieren )
  • Access 2010 Replikation mit TSI Synchronizer 4.0
  • DZR30.08.20 20:18
       └ RE: Access 2010 Replikation mit TSI Synchronizer... PeterDoering31.08.20 00:47
          └ RE: Access 2010 Replikation mit TSI Synchroniz... DZR31.08.20 11:47
             └ RE: Access 2010 Replikation mit TSI Synchron... DZR31.08.20 12:26
                └ RE: Access 2010 Replikation mit TSI Synchr... PeterDoering31.08.20 23:52
                   └ RE: Access 2010 Replikation mit TSI Sync... DZR01.09.20 10:04
  • Import per VBA von einer Gupta DB
  • rwolfertz26.08.20 16:07
       └ RE: Import per VBA von einer Gupta DB PeterDoering26.08.20 17:41
          └ RE: Import per VBA von einer Gupta DB rwolfertz27.08.20 14:20
             └ RE: Import per VBA von einer Gupta DB PeterDoering27.08.20 15:19
                └ RE: Import per VBA von einer Gupta DB rwolfertz31.08.20 11:22
  • 3.1 Tabellen wieder einbinden
  • Mario Nestelberger26.08.20 12:18
       └ RE: 3.1 Tabellen wieder einbinden Karl Donaubauer27.08.20 13:04
          └ RE: 3.1 Tabellen wieder einbinden Mario Nestelberger28.08.20 16:56
             └ RE: 3.1 Tabellen wieder einbinden Karl Donaubauer28.08.20 20:49
                └ RE: 3.1 Tabellen wieder einbinden Mario Nestelberger30.08.20 21:43
                   └ RE: 3.1 Tabellen wieder einbinden PeterDoering30.08.20 22:45
                      └ vielleicht bin ich ein Idiot ..... Mario Nestelberger31.08.20 01:13
  • Wie kann ich dieses Problem umsetzen?
  • AccessNutzer24.08.20 07:57
       └ RE: Wie kann ich dieses Problem umsetzen? Tarzun24.08.20 17:15
  • Wunderliches MSACCESS - Performance
  • Tarzun20.08.20 15:02
       └ RE: Wunderliches MSACCESS - Performance PeterDoering21.08.20 20:54
          └ RE: Wunderliches MSACCESS - Performance Tarzun24.08.20 16:29
  • Access-Fenster wechseln spontan in den Vordergrund
  • Pochmann-IT04.08.20 17:44
       └ RE: Access-Fenster wechseln spontan in den Vorde... StefanWirrer20.08.20 14:08
  • Einladung zum 2. virtuellen Access-Stammtisch Hann...
  • KlausWerther19.08.20 12:15
  • Access Stammtisch München am 13.08.2020 (Do)
  • StefanWirrer11.08.20 14:06
  • Probleme mit Combobox und Autoexpand
  • KatrinCou07.08.20 12:09
  • Import-Spezifikation
  • Marzer15.07.20 18:30
       └ RE: Import-Spezifikation PeterDoering16.07.20 01:26
          └ RE: Import-Spezifikation Marzer19.07.20 21:53
  • Verbindung zu SQL-Server läuft auf Automatisierung...
  • willi15426.06.20 11:59
       └ RE: Verbindung zu SQL-Server läuft auf Automatis... willi15409.07.20 09:23
  • Access Stammtisch München am 09.07.2020 (Do)
  • StefanWirrer09.07.20 08:30
  • nochmals Access 2016 Runtime - Absturz - Bug?
  • Mario Nestelberger03.07.20 19:46
  • Runtime Version von Access 2016 ein Scherz ?
  • Neuling23.06.20 18:40
       └ RE: Runtime Version von Access 2016 ein Scherz ? Karl Donaubauer24.06.20 09:50
  • Typen unverträglich
  • SoeSchi23.06.20 07:34
       └ RE: Typen unverträglich PeterDoering23.06.20 11:54
          └ RE: Typen unverträglich SoeSchi23.06.20 14:45
    KatrinCou
    Gesendet: 07.08.20 12:09
    Betreff: Probleme mit Combobox und Autoexpand


    New user

    Beiträge: 1

    Hallo,
    ich habe seit der Umstellung von Windows7/Access 2010 Prof (32bit) auf Windows 10/ Access 2016 Prof(32bit) ein spezielles Problem mit Comboboxen und der Autoexpand-Funktion, das mich schon längere Zeit beschäftigt:
    Wenn in einer Combobox vom Anwender ein Wert eingegeben wird, zeigt Access automatisch den nächsten passenden Wert aus der Liste an. Das funktioniert aber unter der neuen Systemumgebung nur für die ersten 50 Listeneinträge. Ab der 51 Zeile, wird der Wert nicht mehr angezeigt, erst wenn das Feld verlassen wird.
    Wenn ich per VBA zuvor über das Feld-Ereignis Change ein "dropdown" sende oder manuell die Combobox aufklappe, funktioniert die Autoexpand-Funktion fehlerfrei.

    Nach vielen schrittweisen Analysen habe ich festgestellt, dass diese folgenden Punkte Auswirkungen auf den Fehler haben, die in einer neuen accdb mit einem Testformular und Testtabelle bei mir nachvollziehbar sind:
    -Wenn im Formular Tastenvorschau = JA und form_Keydown-Ereginis => geht nicht
    (selbst wenn Source-Code ausdokumentiert ist von keydown-Ereignis)
    -Wenn im Formular Tastenvorschau = NEIN => geht
    -Wenn im Formular Tastenvorschau = JA und form_KeydUP-Ereginis => geht
    ABER ich benötige Keydown und nicht keyup Ereignis)

    -Distinct in Abfragen hat auch keine Auswirkungen gezeigt
    -Tritt sowohl bei verknüpfter SQL-Server-Tabelle auf als auch bei lokaler Tabelle auf
    -Das Problem tritt nicht auf wenn ich die gleiche Anwendung auf dem Produktivsystem mit Windows 7/Office 2010 verteile

    -Wenn der Verweis auf die MS Common-Control SP6 (mscomctl.ocx) integriert ist= >geht nicht
    -Wenn der Verweise auf die MS Common-Control SP6 (mscomctl.ocx) entfernt wird=> geht!!!
    -mscomctl.ocx ist vom 08.12.2015(Version 6.1.98.46) habe diese noch mal neu registriert => geht nicht
    (benötige den Verweis für Datepicker und Listfelder)

    Hat jemand vielleicht noch eine Idee was ich machen kann, bevor ich umfangreiche Änderungen integrieren muss? Liegt es evtl. an einer falschen mscomctl.ocx?
    Ich hatte diese noch mal runtergeladen von der MS-Site: https://www.microsoft.com/de-de/download/details.aspx?id=10019. Aber alle Funktionen der damit integrierten Steuerelemente funktionieren.

    Danke und schöne Grüße
    Katrin
    Top of the page Bottom of the page


    Seite: < 1 2 3 4 5 6 7 8 9 10 11 ... >
    Suche in diesem Forum
    Druckfreundliche Version
    (Alle Cookies von dieser Seite löschen.)