Suche | Statistiken | Benutzerliste | Access-FAQ | Datenschutz Foren
donkarl Forum
donkarl Forum ->  Themen -> Access -> Diskussion ansehen

Du bist als Gast eingelogt. ( Anmelden | Registrieren )
  • Access Stammtisch München am 08.02.2024 (Do)
  • StefanWirrer07.02.24 09:16
  • Bug in Filterfunktion der Datenblätter
  • sks14.01.24 18:39
       └ RE: Bug in Filterfunktion der Datenblätter PeterDoering14.01.24 22:11
          └ RE: Bug in Filterfunktion der Datenblätter sks15.01.24 08:13
          └ RE: Bug in Filterfunktion der Datenblätter sks15.01.24 10:06
       └ RE: Bug in Filterfunktion der Datenblätter sks06.02.24 21:42
  • Access-Verzeichnis nicht mehr vertrauenswürdig?
  • Lorenz09.01.24 18:40
       └ RE: Access-Verzeichnis nicht mehr vertrauenswürd... Karl Donaubauer09.01.24 22:24
          └ RE: Access-Verzeichnis nicht mehr vertrauenswü... Lorenz10.01.24 08:48
             └ RE: Access-Verzeichnis nicht mehr vertrauens... Lorenz10.01.24 08:51
                └ RE: Access-Verzeichnis nicht mehr vertraue... Karl Donaubauer10.01.24 09:45
                   └ RE: Access-Verzeichnis nicht mehr vertra... Lorenz10.01.24 10:13
                      └ GELÖST: Access-Verzeichnis nicht mehr ... Lorenz01.02.24 07:42
                         └ RE: GELÖST: Access-Verzeichnis nicht... Karl Donaubauer01.02.24 11:03
  • Meldung Fehler beim Laden einer DLL ???
  • Paula30.01.24 20:49
       └ RE: Meldung Fehler beim Laden einer DLL ??? Karl Donaubauer31.01.24 10:25
          └ RE: Meldung Fehler beim Laden einer DLL ??? Paula31.01.24 19:24
  • Kombinationsfeld reagiert nicht ????
  • Paula17.01.24 18:11
       └ RE: Kombinationsfeld reagiert nicht ???? Karl Donaubauer17.01.24 18:50
       └ RE: Kombinationsfeld reagiert nicht ???? Ulrich6317.01.24 18:52
       └ RE: Kombinationsfeld reagiert nicht ???? Paula18.01.24 17:54
  • Beziehungen
  • Paula09.01.24 17:59
       └ RE: Beziehungen Lorenz10.01.24 11:42
          └ RE: Beziehungen Paula11.01.24 19:47
             └ RE: Beziehungen Lorenz12.01.24 06:55
  • msaccess hängt sich auf
  • Greiff10.01.24 13:14
       └ RE: msaccess hängt sich auf PeterDoering10.01.24 14:41
       └ RE: msaccess hängt sich auf Karl Donaubauer10.01.24 14:46
          └ RE: msaccess hängt sich auf Greiff11.01.24 00:57
             └ RE: msaccess hängt sich auf Karl Donaubauer11.01.24 11:04
                └ RE: msaccess hängt sich auf Greiff11.01.24 12:14
                   └ RE: msaccess hängt sich auf Karl Donaubauer11.01.24 12:50
  • Access und SQL-Server Replikation
  • BMAJ11.01.24 10:21
  • Access Stammtisch München am 11.01.2024 (Do)
  • StefanWirrer10.01.24 09:25
  • Hinweis: TeamViewer-Probleme
  • Lorenz09.01.24 18:45
  • seltsames Verhalten von Unterformular
  • BMAJ03.01.24 14:34
       └ RE: seltsames Verhalten von Unterformular PeterDoering04.01.24 10:49
          └ RE: seltsames Verhalten von Unterformular BMAJ04.01.24 12:02
          └ RE: seltsames Verhalten von Unterformular BMAJ09.01.24 11:38
  • Performance Einbruch
  • ASummer21.12.23 12:31
       └ RE: Performance Einbruch Karl Donaubauer21.12.23 13:14
          └ RE: Performance Einbruch ASummer21.12.23 16:09
       └ RE: Performance Einbruch PeterDoering21.12.23 16:09
          └ RE: Performance Einbruch ASummer02.01.24 15:31
             └ RE: Performance Einbruch PeterDoering02.01.24 19:42
             └ RE: Performance Einbruch BMAJ03.01.24 14:38
  • Neuerdings Probleme bei csv-Export
  • Andrea02.01.24 12:15
       └ RE: Neuerdings Probleme bei csv-Export Karl Donaubauer02.01.24 14:28
          └ RE: Neuerdings Probleme bei csv-Export Andrea02.01.24 14:41
             └ RE: Neuerdings Probleme bei csv-Export Karl Donaubauer02.01.24 14:50
  • Access Stammtisch München am 14.12.2023 (Do)
  • StefanWirrer11.12.23 16:06
  • A365 Label und Textbox
  • olecundbolec22.11.23 14:58
       └ RE: A365 Label und Textbox PeterDoering22.11.23 16:07
          └ RE: A365 Label und Textbox olecundbolec23.11.23 08:55
             └ RE: A365 Label und Textbox PeterDoering28.11.23 19:29
    BMAJ
    Gesendet: 03.01.24 14:34
    Betreff: seltsames Verhalten von Unterformular


    Member

    Beiträge: 17

    Hallo Access-Profis,

    ich muss nochmal ein sehr seltsames Phänomen posten, welches uns seit gewisser Zeit Probleme bereitet.

    Hintergrundinfos:

    Access 2019 Version 1808 (Build 10405.20015)

    Backend: SQL-Server 2019 15.0.4335.1

    Wir haben eine Access CRM-Anwedung in der Kundendaten aufgerufen werden können über ein Hauptformular wird ein Unterformular angezeigt mit Ansprechpartner zum Kunden.
    Hauptformular und Unterformular sind miteinander über die jeweiligen Felder der Kundennummer verknüpft.

    Das funktioniert auch in der Regel problemlos. Allerdings tritt seit etwa 2 Jahren ein seltsames Phänomen sporadisch auf:

    Trägt man im Unterformular neue Ansprechpartner am Kunden ein und verlässt dann das Unterformular erscheint sporadisch nicht der gerade eingetragene Ansprechpartner sondern irgendein anderer von einem anderen Kunden.
    In der Datenbank ist die Zuweisung aber immer zum richtigen Kunden. Es ist also ein reiner Anzeige Fehler. Aktualisiert man die Anzeige wird es auch wieder richtig angezeigt.
    Das Problem ist, dass es die Anwender nicht immer sofort sehen und dann denken der Eintrag wäre falsch, diesen überschreiben und dann ist aber der Ansprechpartner eines ganz anderen Kunden überschrieben.

    Es ist möglich, dass dieses Phänomen erst aufgetreten ist seitdem wir die SQL-Datenbank (Backend) per Mergereplikation an einen anderen SQL-Server replizieren. (für eine mobile App für unsere Außendienstmitarbeiter)
    Denn: wir haben exakt die gleiche Anwendung am anderen Standort im Einsatz. Hier tritt das Phänomen nicht auf. Es ist alles exakt gleich bis auf die Daten an sich (andere Kundendaten) und keine Replizierung auf Datenbankebene.

    Wie eine Replizierung aber zu diesem Phänomen führen soll ist mir rätselhaft. Und wenn es daran liegt wieso tritt es nicht jedes mal auf sondern nur sporadisch.

    Aktuell behelfen wir uns indem der Anwendung nachdem eintragen/ändern eines Ansprechpartners im Unterformular direkt auf einen Button klickt der die Daten im Formular aktualisiert, somit aktualisiert sich die Anzeige und die Daten werden dann auch korrekt angezeigt.

    Vielleicht hat ja jemand einen Ansatz dazu oder es ist irgendwo bereits ein ähnlicher Bug bekannt?
    Top of the page Bottom of the page


    Seite: < 1 2 3 4 5 6 7 8 9 ... >
    Suche in diesem Forum
    Druckfreundliche Version
    (Alle Cookies von dieser Seite löschen.)